[evolvis-commits] r18291: Prepared new upstream release..

mirabilos at evolvis.org mirabilos at evolvis.org
Wed Apr 11 11:16:10 CEST 2012


Author: mirabilos
Date: 2012-04-11 11:16:10 +0200 (Wed, 11 Apr 2012)
New Revision: 18291

Modified:
   trunk/mediawiki/debian/README.Debian
   trunk/mediawiki/debian/changelog
   trunk/mediawiki/debian/control
   trunk/mediawiki/debian/control.in
   trunk/mediawiki/debian/copyright
   trunk/mediawiki/debian/patches/debian_specific_config.patch
   trunk/mediawiki/debian/patches/mimetypes.patch
   trunk/mediawiki/debian/patches/texvc_location.patch
   trunk/mediawiki/debian/po/ja.po
   trunk/mediawiki/debian/rules
Log:
Prepared new upstream release..

Modified: trunk/mediawiki/debian/README.Debian
===================================================================
--- trunk/mediawiki/debian/README.Debian	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/README.Debian	2012-04-11 09:16:10 UTC (rev 18291)
@@ -69,7 +69,7 @@
 	2) Copy the configuration files from /etc/mediawiki1.x to /var/lib/mediawiki and make them writable for
 	     your webserver user -- usualy www-data.
 		cp /var/lib/mediawiki1.x/LocalSettings.php /etc/mediawiki
-		cp /var/mediawiki1.x/AdminSettings.php /etc/mediawiki (if exists)
+		cp /var/lib/mediawiki1.x/AdminSettings.php /etc/mediawiki (if exists)
 	3) Add the following line at the begining of your /etc/mediawiki/LocalSettings.php if it does not exist:
 		define(MW_INSTALL_PATH,"/var/lib/mediawiki");
 	4) Execute the update script:

Modified: trunk/mediawiki/debian/changelog
===================================================================
--- trunk/mediawiki/debian/changelog	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/changelog	2012-04-11 09:16:10 UTC (rev 18291)
@@ -1,3 +1,25 @@
+mediawiki (1:1.14.0-1) unstable; urgency=low
+
+  * New upstream release.
+  * Fixed issues in the installer:
+  "A number of cross-site scripting (XSS) security vulnerabilities were
+   discovered in the web-based installer (config/index.php). 
+   These vulnerabilities all require a live installer once the installer 
+   has been used to install a wiki, it is deactivated.
+
+   Note that cross-site scripting vulnerabilities can be used to attack
+   any website in the same cookie domain. So if you have an uninstalled 
+   copy of MediaWiki on the same site as an active web service, MediaWiki 
+   could be used to attack the active service."
+  Closes: #514547
+  * Fixed typo in README.Debian
+  Closes: #515192
+  * Updated japanese debconf translation, thanks to Hideki Yamane
+  Closes: #510896
+  * Added a file in debian/copyright
+
+ -- Romain Beauxis <toots at rastageeks.org>  Fri, 06 Mar 2009 20:29:17 +0100
+
 mediawiki (1:1.13.3-1) unstable; urgency=low
 
   * New upstream release.

Modified: trunk/mediawiki/debian/control
===================================================================
--- trunk/mediawiki/debian/control	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/control	2012-04-11 09:16:10 UTC (rev 18291)
@@ -25,7 +25,9 @@
 
 Package: mediawiki-math
 Architecture: any
-Depends: ${interpreter:Depends}, texlive-latex-base, ghostscript, imagemagick, ${shlibs:Depends}
+Depends: ${interpreter:Depends}, texlive-latex-base, 
+         ghostscript, imagemagick, 
+         ${shlibs:Depends}, ${misc:Depends}
 Replaces: mediawiki1.5-math, mediawiki1.9-math, mediawiki1.10-math
 Recommends: mediawiki, latex-cjk-all, texlive-latex-extra 
 Description: math rendering plugin for MediaWiki

Modified: trunk/mediawiki/debian/control.in
===================================================================
--- trunk/mediawiki/debian/control.in	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/control.in	2012-04-11 09:16:10 UTC (rev 18291)
@@ -25,7 +25,9 @@
 
 Package: mediawiki-math
 Architecture: any
-Depends: ${interpreter:Depends}, texlive-latex-base, ghostscript, imagemagick, ${shlibs:Depends}
+Depends: ${interpreter:Depends}, texlive-latex-base, 
+         ghostscript, imagemagick, 
+         ${shlibs:Depends}, ${misc:Depends}
 Replaces: mediawiki1.5-math, mediawiki1.9-math, mediawiki1.10-math
 Recommends: mediawiki, latex-cjk-all, texlive-latex-extra 
 Description: math rendering plugin for MediaWiki

Modified: trunk/mediawiki/debian/copyright
===================================================================
--- trunk/mediawiki/debian/copyright	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/copyright	2012-04-11 09:16:10 UTC (rev 18291)
@@ -66,6 +66,7 @@
 // |   client logic under 2-clause BSD license.                                |
 // +---------------------------------------------------------------------------+
 
+   File button_S_italic.png is licensed under the public domain.
 
    Images found on the common skins icons images are licensed under 
    GNU LGPL License.

Modified: trunk/mediawiki/debian/patches/debian_specific_config.patch
===================================================================
--- trunk/mediawiki/debian/patches/debian_specific_config.patch	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/patches/debian_specific_config.patch	2012-04-11 09:16:10 UTC (rev 18291)
@@ -1,8 +1,8 @@
-Index: mediawiki-1.13.0/config/index.php
+Index: mediawiki-1.14.0/config/index.php
 ===================================================================
---- mediawiki-1.13.0.orig/config/index.php	2008-07-20 16:29:04.000000000 +0200
-+++ mediawiki-1.13.0/config/index.php	2008-08-17 11:12:07.000000000 +0200
-@@ -223,7 +223,7 @@
+--- mediawiki-1.14.0.orig/config/index.php	2009-02-20 15:17:47.000000000 +0100
++++ mediawiki-1.14.0/config/index.php	2009-03-06 20:46:47.000000000 +0100
+@@ -226,7 +226,7 @@
  if( !is_writable( "." ) ) {
  	dieout( "<h2>Can't write config file, aborting</h2>
  
@@ -11,7 +11,7 @@
  	writable by the web server. Once configuration is done you'll move the created
  	<tt>LocalSettings.php</tt> to the parent directory, and for added safety you can
  	then remove the <tt>config</tt> subdirectory entirely.</p>
-@@ -1472,16 +1472,7 @@
+@@ -1512,16 +1512,7 @@
  <div class="success-box">
  <p>Installation successful!</p>
  <p>To complete the installation, please do the following:
@@ -29,7 +29,7 @@
  </div>
  EOT;
  	} else {
-@@ -1489,7 +1480,7 @@
+@@ -1529,7 +1520,7 @@
  <div class="success-box">
  <p>
  <span class="success-message">Installation successful!</span>
@@ -38,7 +38,7 @@
  <a href="../$script"> this link</a> to your wiki.</p>
  <p>You should change file permissions for <tt>LocalSettings.php</tt> as required to
  prevent other users on the server reading passwords and altering configuration data.</p>
-@@ -1630,6 +1621,12 @@
+@@ -1677,6 +1668,12 @@
  
  # If you customize your file layout, set \$IP to the directory that contains
  # the other MediaWiki files. It will be used as a base to locate files.
@@ -51,7 +51,7 @@
  if( defined( 'MW_INSTALL_PATH' ) ) {
  	\$IP = MW_INSTALL_PATH;
  } else {
-@@ -1724,6 +1721,11 @@
+@@ -1776,6 +1773,11 @@
  
  \$wgDiff3 = \"{$slconf['diff3']}\";
  

Modified: trunk/mediawiki/debian/patches/mimetypes.patch
===================================================================
--- trunk/mediawiki/debian/patches/mimetypes.patch	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/patches/mimetypes.patch	2012-04-11 09:16:10 UTC (rev 18291)
@@ -1,8 +1,8 @@
-Index: mediawiki-1.13.0/includes/DefaultSettings.php
+Index: mediawiki-1.14.0/includes/DefaultSettings.php
 ===================================================================
---- mediawiki-1.13.0.orig/includes/DefaultSettings.php	2008-08-17 11:10:34.000000000 +0200
-+++ mediawiki-1.13.0/includes/DefaultSettings.php	2008-08-17 11:11:45.000000000 +0200
-@@ -343,8 +343,8 @@
+--- mediawiki-1.14.0.orig/includes/DefaultSettings.php	2009-03-06 20:46:45.000000000 +0100
++++ mediawiki-1.14.0/includes/DefaultSettings.php	2009-03-06 20:46:46.000000000 +0100
+@@ -345,8 +345,8 @@
  $wgVerifyMimeType= true;
  
  /** Sets the mime type definition file to use by MimeMagic.php. */

Modified: trunk/mediawiki/debian/patches/texvc_location.patch
===================================================================
--- trunk/mediawiki/debian/patches/texvc_location.patch	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/patches/texvc_location.patch	2012-04-11 09:16:10 UTC (rev 18291)
@@ -1,8 +1,8 @@
-Index: mediawiki-1.13.0/includes/DefaultSettings.php
+Index: mediawiki-1.14.0/includes/DefaultSettings.php
 ===================================================================
---- mediawiki-1.13.0.orig/includes/DefaultSettings.php	2008-08-17 11:10:06.000000000 +0200
-+++ mediawiki-1.13.0/includes/DefaultSettings.php	2008-08-17 11:10:24.000000000 +0200
-@@ -1606,7 +1606,7 @@
+--- mediawiki-1.14.0.orig/includes/DefaultSettings.php	2009-02-22 11:27:52.000000000 +0100
++++ mediawiki-1.14.0/includes/DefaultSettings.php	2009-03-06 20:46:55.000000000 +0100
+@@ -1714,7 +1714,7 @@
   */
  $wgUseTeX = false;
  /** Location of the texvc binary */

Modified: trunk/mediawiki/debian/po/ja.po
===================================================================
--- trunk/mediawiki/debian/po/ja.po	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/po/ja.po	2012-04-11 09:16:10 UTC (rev 18291)
@@ -1,14 +1,16 @@
-# Japanese debconf templates translation for mediawiki1.9.
-# Copyright (C) 2007 Noritada Kobayashi
-# This file is distributed under the same license as the mediawiki1.9 package.
-#
+# Japanese debconf templates translation for mediawiki.
+# Copyright (C) 2009 Mediawiki Maintenance Team <pkg-mediawiki-devel at lists.alioth.debian.org>
+# This file is distributed under the same license as the mediawiki package.
+# Noritada Kobayashi <noritadak at gmail.com>, 2007.
+# Hideki Yamane (Debian-JP) <henrich at debian.or.jp>, 2009.
+
 msgid ""
 msgstr ""
-"Project-Id-Version: mediawiki1.9 (debconf) 1.9.1-9\n"
+"Project-Id-Version: mediawiki 1:1.13.3-1\n"
 "Report-Msgid-Bugs-To: pkg-mediawiki-devel at lists.alioth.debian.org\n"
 "POT-Creation-Date: 2007-10-22 02:37+0200\n"
-"PO-Revision-Date: 2007-03-01 22:44+0900\n"
-"Last-Translator: Noritada Kobayashi <nori1 at dolphin.c.u-tokyo.ac.jp>\n"
+"PO-Revision-Date: 2009-01-05 22:44+0900\n"
+"Last-Translator: Hideki Yamane (Debian-JP) <henrich at debian.or.jp>\n"
 "Language-Team: Japanese <debian-japanese at lists.debian.org>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
@@ -17,82 +19,14 @@
 #. Type: multiselect
 #. Description
 #: ../templates:2001
-#, fuzzy
 msgid "Web server(s) to configure automatically:"
 msgstr "自動的に設定を行うウェブサーバ:"
 
 #. Type: multiselect
 #. Description
 #: ../templates:2001
-#, fuzzy
 msgid ""
 "Please select the web server(s) that should be configured automatically for "
 "MediaWiki."
-msgstr "自動的に設定を行うウェブサーバ:"
+msgstr "MediaWiki の設定を自動的に行います。対象のウェブサーバを選択してください。"
 
-#, fuzzy
-#~ msgid "Perform upgrade from:"
-#~ msgstr "mediawiki1.7 から自動的にアップグレードしますか?"
-
-#, fuzzy
-#~ msgid ""
-#~ "If you choose to upgrade MediaWiki automatically, the database will be "
-#~ "backed up, upgraded, and a new configuration file will be prepared. "
-#~ "Alternatively, you can perform it later with the '/usr/share/mediawiki/"
-#~ "debian-scripts/upgrade-mediawiki' command."
-#~ msgstr ""
-#~ "このパッケージでは、アップグレードを自動的に行うスクリプトが提供されていま"
-#~ "す。スクリプトを実行すると、データベースのバックアップをとった上でアップグ"
-#~ "レードを実行し、新しい mediawiki 用の設定ファイルを新たに準備します。この"
-#~ "スクリプトは、後から root で /usr/share/mediawiki1.9/debian-scripts/"
-#~ "upgrade-mediawiki1.7 を呼び出して使用することも可能です。"
-
-#, fuzzy
-#~ msgid "MediaWiki database administrative user:"
-#~ msgstr "mediawiki1.9 の管理用ユーザ:"
-
-#, fuzzy
-#~ msgid ""
-#~ "Please provide a MySQL account that has administrative access to the old "
-#~ "MediaWiki database."
-#~ msgstr ""
-#~ "古い mediawiki1.7 のデータベースに管理者権限でアクセスできる mysql アカウ"
-#~ "ントを入力してください。"
-
-#, fuzzy
-#~ msgid ""
-#~ "An AdminSettings.php file will be generated unless the root account is "
-#~ "specified."
-#~ msgstr ""
-#~ "AdminSettings.php ファイルが生成されます。もちろん、root アカウントを指定"
-#~ "した場合はこのファイルは削除されます。"
-
-#, fuzzy
-#~ msgid "MediaWiki database administrative password:"
-#~ msgstr "mediawiki1.9 の管理用パスワード:"
-
-#, fuzzy
-#~ msgid ""
-#~ "Please specify the password of the MySQL account with administrative "
-#~ "access to the old MediaWiki database."
-#~ msgstr ""
-#~ "古い mediawiki1.7 のデータベースに管理者権限でアクセスできる mysql アカウ"
-#~ "ントを入力してください。"
-
-#~ msgid "You are upgrading from mediawiki1.7."
-#~ msgstr "mediawiki1.7 からアップグレードしています。"
-
-#~ msgid ""
-#~ "This package will install its files in a new location:\n"
-#~ " /var/lib/mediawiki1.9\n"
-#~ "Then you need to upgrade your old mediawiki1.7."
-#~ msgstr ""
-#~ "このパッケージではファイルが次の新しい場所にインストールされます:\n"
-#~ " /var/lib/mediawiki1.9\n"
-#~ "したがって、古い mediawiki1.7 をアップグレードする必要があります。"
-
-#~ msgid "If you don't know any account, the root user is sufficient."
-#~ msgstr "アカウントがわからない場合は root ユーザで十分です。"
-
-#~ msgid "Please give the password for the account you specified."
-#~ msgstr "指定したアカウントのパスワードを入力してください。"

Modified: trunk/mediawiki/debian/rules
===================================================================
--- trunk/mediawiki/debian/rules	2012-04-11 09:16:09 UTC (rev 18290)
+++ trunk/mediawiki/debian/rules	2012-04-11 09:16:10 UTC (rev 18291)
@@ -38,6 +38,7 @@
 	# License added to copyright file:
 	rm -f debian/mediawiki/usr/share/mediawiki/skins/common/images/icons/COPYING
 	rm -f debian/mediawiki/usr/share/mediawiki/skins/common/images/cyrl/LICENSE
+	rm -f debian/mediawiki/usr/share/mediawiki/skins/common/images/ksh/LICENSE
 
 binary-install/mediawiki-math::
 	if [ -x /usr/bin/ocamlopt ]; then\



More information about the evolvis-commits mailing list