[evolvis-commits] r18490: move MW ext deps to ff-p-mw; nail versions even tighter

mirabilos at evolvis.org mirabilos at evolvis.org
Thu Jul 12 13:41:56 CEST 2012


Author: mirabilos
Date: 2012-07-12 13:41:55 +0200 (Thu, 12 Jul 2012)
New Revision: 18490

Modified:
   trunk/gforge_base/evolvisforge-5.1/src/packaging/control/900evolvis-meta
   trunk/gforge_base/evolvisforge-5.1/src/plugins/mediawiki/packaging/control/160plugin-mediawiki
Log:
move MW ext deps to ff-p-mw; nail versions even tighter

Modified: trunk/gforge_base/evolvisforge-5.1/src/packaging/control/900evolvis-meta
===================================================================
--- trunk/gforge_base/evolvisforge-5.1/src/packaging/control/900evolvis-meta	2012-07-12 11:26:22 UTC (rev 18489)
+++ trunk/gforge_base/evolvisforge-5.1/src/packaging/control/900evolvis-meta	2012-07-12 11:41:55 UTC (rev 18490)
@@ -12,10 +12,7 @@
  locales-all | language-pack-de,
  locales-all | language-pack-en,
  @PACKAGE at -plugin-extratabs, @PACKAGE at -plugin-projectlabels,
- @PACKAGE at -plugin-mediawiki, mediawiki-extensions-base (>= 2.4~),
- mediawiki-extensions-base (<< 2.7~),
- mediawiki-math (<< 1:1.16), mediawiki-extensions-collection,
- mediawiki-extensions-geshi, mediawiki-extensions-graphviz,
+ @PACKAGE at -plugin-mediawiki,
  evolvisforge-common, evolvisforge-web-apache2,
  evolvisforge-db-postgresql, evolvisforge-mta-postfix,
  evolvisforge-shell-postgresql, evolvisforge-lists-mailman,

Modified: trunk/gforge_base/evolvisforge-5.1/src/plugins/mediawiki/packaging/control/160plugin-mediawiki
===================================================================
--- trunk/gforge_base/evolvisforge-5.1/src/plugins/mediawiki/packaging/control/160plugin-mediawiki	2012-07-12 11:26:22 UTC (rev 18489)
+++ trunk/gforge_base/evolvisforge-5.1/src/plugins/mediawiki/packaging/control/160plugin-mediawiki	2012-07-12 11:41:55 UTC (rev 18490)
@@ -1,5 +1,18 @@
 Package: @PACKAGE at -plugin-mediawiki
 Architecture: all
-Depends: @OLDPACKAGE at -common (>= 4.8), @OLDPACKAGE at -db-postgresql (>= 4.8) | @OLDPACKAGE at -db, @OLDPACKAGE at -web-apache2 (>= 4.8) | @OLDPACKAGE at -web, postgresql-contrib | mysql-server, mediawiki (>= 1:1.15.5-10~), mediawiki (<< 1:1.16), php5-cli, php5-gd, ${misc:Depends}, @OLDPACKAGE at -plugin-mediawiki (>= 5.1.1+evolvis41~)
+Depends: @OLDPACKAGE at -common (>= 4.8),
+ @OLDPACKAGE at -db-postgresql (>= 4.8) | @OLDPACKAGE at -db,
+ @OLDPACKAGE at -web-apache2 (>= 4.8) | @OLDPACKAGE at -web,
+ postgresql-contrib | mysql-server,
+ mediawiki (>= 1:1.15.5-10~), mediawiki (<< 1:1.16),
+ mediawiki-extensions-base (>= 2.4~),
+ mediawiki-extensions-base (<< 2.7~),
+ mediawiki-math (<< 1:1.16),
+ mediawiki-extensions-collection (<< 2.7~),
+ mediawiki-extensions-geshi (<< 2.7~),
+ mediawiki-extensions-graphviz (<< 2.7~),
+ php5-cli, php5-gd,
+ @OLDPACKAGE at -plugin-mediawiki (>= 5.1.1+evolvis41~),
+ ${misc:Depends}
 Provides: evolvisforge-plugin-mediawiki-ff
 Description: Mediawiki plugin for FusionForge



More information about the evolvis-commits mailing list