update maintainer script documentation
authormirabilos <m@mirbsd.org>
Mon, 2 May 2016 08:02:37 +0000 (10:02 +0200)
committermirabilos <m@mirbsd.org>
Mon, 2 May 2016 08:02:37 +0000 (10:02 +0200)
debian/joe-jupp.prerm
debian/jupp.postrm
debian/jupp.preinst
debian/jupp.prerm

index 0dbc1d9..962b4ff 100644 (file)
@@ -14,6 +14,7 @@ set -e
 # have previously been configured and not removed.
 #
 # * new-prerm "failed-upgrade" $old_version
+# * new-prerm "failed-upgrade" $old_version $new_version # 1.18.5, stretch
 # Called when 'old-prerm "upgrade"' fails; new package not unpacked, all
 # other constraints the same as above.
 
index d9208a8..862937f 100644 (file)
@@ -12,12 +12,15 @@ set -e
 # kages may be available; skip gracefully actions requiring Depends.
 #
 # * new-postrm "failed-upgrade" $old_version
+# * new-postrm "failed-upgrade" $old_version $new_version # 1.18.5, stretch
 # Called when 'old-postrm "upgrade"' fails; the new package is unpacked,
 # Essential packages and Pre-Depends are available; the latter have been
 # configured and never removed but may be Unpacked or Half-Configured.
 #
 # * new-postrm "abort-install" [$old_version]
+# * new-postrm "abort-install" $old_version $new_version # 1.18.5, stretch
 # * new-postrm "abort-upgrade" $old_version
+# * new-postrm "abort-upgrade" $old_version $new_version # 1.18.5, stretch
 # Called when preinst fails; package is not unpacked. Essential packages
 # and (unpacked or Half-Configured) Pre-Depends are available.
 
index 03d2d2c..689543a 100644 (file)
@@ -5,7 +5,9 @@ set -e
 # This maintainer script can be called the following ways:
 #
 # * new-preinst "install" [$old_version]
+# * new-preinst "install" $old_version $new_version # 1.18.5, stretch
 # * new-preinst "upgrade" [$old_version]
+# * new-preinst "upgrade" $old_version $new_version # 1.18.5, stretch
 # * old-preinst "abort-upgrade" $new_version
 # Essential packages and Pre-Depends are available. Pre-Depends have
 # been configured once, but may be unpacked or Half-Configured only,
index 115b877..36ad3b7 100644 (file)
@@ -14,6 +14,7 @@ set -e
 # have previously been configured and not removed.
 #
 # * new-prerm "failed-upgrade" $old_version
+# * new-prerm "failed-upgrade" $old_version $new_version # 1.18.5, stretch
 # Called when 'old-prerm "upgrade"' fails; new package not unpacked, all
 # other constraints the same as above.