Try debhelper compat 9
authormirabilos <m@mirbsd.org>
Sat, 8 Oct 2016 19:15:52 +0000 (21:15 +0200)
committermirabilos <m@mirbsd.org>
Sat, 8 Oct 2016 19:15:52 +0000 (21:15 +0200)
debian/changelog
debian/compat
debian/control
debian/source.lintian-overrides

index 42811ed..aff9ef3 100644 (file)
@@ -4,11 +4,11 @@ jupp (3.1.29~pre1-1) unstable; urgency=low
   * New upstream prerelease
   * Update maintainer script documentation
   * Bump Policy (no change necessary)
-  * Update lintian overrides
   * Fix VCS-* as lintian prompted
   * Apply lintian’s spell fixes
+  * Try debhelper compat 9
 
- -- Thorsten Glaser <tg@mirbsd.de>  Sat, 08 Oct 2016 21:12:01 +0200
+ -- Thorsten Glaser <tg@mirbsd.de>  Sat, 08 Oct 2016 21:15:30 +0200
 
 jupp (3.1.28-1) unstable; urgency=medium
 
index 7ed6ff8..ec63514 100644 (file)
@@ -1 +1 @@
-5
+9
index 9a15d8a..7750894 100644 (file)
@@ -4,8 +4,8 @@ Priority: optional
 Maintainer: Thorsten Glaser <tg@mirbsd.de>
 Homepage: https://www.mirbsd.org/jupp.htm
 # Just drop B-D on autotools-dev or libselinux1-dev if needed,
-# as they are optional and autodetected.
-Build-Depends: debhelper (>= 5),
+# as they are optional and autodetected; debhelper 5 is enough.
+Build-Depends: debhelper (>= 9),
   autotools-dev,
 # libselinux1-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386],
   libselinux1-dev [linux-any],
index fec99d7..e80b0c2 100644 (file)
@@ -3,6 +3,3 @@ jupp source: debian-watch-may-check-gpg-signature
 
 # nope, not gonna do
 jupp source: no-dep5-copyright
-
-# currently preferrable
-jupp source: package-uses-old-debhelper-compat-version 5