avoid a lintian warning for using debhelper 9, meh…
authormirabilos <m@mirbsd.org>
Tue, 13 Feb 2018 21:41:24 +0000 (22:41 +0100)
committermirabilos <m@mirbsd.org>
Tue, 13 Feb 2018 21:41:24 +0000 (22:41 +0100)
debian/changelog
debian/rules
debian/source.lintian-overrides

index 8a1a596..9718a5b 100644 (file)
@@ -3,8 +3,9 @@ jupp (3.1.33-1) unstable; urgency=high
   * New upstream release
     - urgency=high due to regression fix and some bugfixes
     - bump dependency from joe-jupp to jupp (new features)
+  * Grudgingly go to debhelper 11
 
- -- Thorsten Glaser <tg@mirbsd.de>  Tue, 13 Feb 2018 22:35:36 +0100
+ -- Thorsten Glaser <tg@mirbsd.de>  Tue, 13 Feb 2018 22:41:06 +0100
 
 jupp (3.1.32-2) unstable; urgency=low
 
index 3c22291..e2d7587 100755 (executable)
@@ -120,7 +120,7 @@ EXTRA_CFLAGS+=              -Wno-unused-parameter -Wno-cast-qual
 EXTRA_CFLAGS+=         -Wno-strict-prototypes
 EXTRA_LDFLAGS=         -Wl,--as-needed
 
-DEBHELPER_VERSION:=    9
+DEBHELPER_VERSION:=    11
 DSF:=                  3.0 (quilt)
 SUBST_EP:=             -e '/@PRIO@EXTRA@/d'
 HOMEPAGE:=             http://www.mirbsd.org/jupp.htm
@@ -128,6 +128,11 @@ SUBST_HP:=         -e '/@HP@DOT@/d' -e '/@HP@OLD@/d' -e 's\ 1@HP@MODERN@\ 1${HOMEPAGE}\ 1'
 SELINUX_DEP:=          libselinux1-dev [linux-any]
 MENU_SUBST:=           cat
 
+# wheezy, jessie, stretch
+ifneq (,$(findstring wheezy,${DEB_BUILD_OPTIONS}))
+DEBHELPER_VERSION:=    9
+endif
+# lenny, squeeze
 ifneq (,$(findstring lenny,${DEB_BUILD_OPTIONS}))
 DEBHELPER_VERSION:=    5
 SELINUX_DEP:=          libselinux1-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386]
@@ -137,6 +142,7 @@ DSF:=                       1.0
 SUBST_EP:=             -e 's/@PRIO@EXTRA@/Priority: extra/'
 BREAKS:=               Conflicts
 endif
+# sarge, etch (although etch has debhelper 5)
 ifneq (,$(findstring sarge,${DEB_BUILD_OPTIONS}))
 DEBHELPER_VERSION:=    4
 SELINUX_DEP:=          libselinux1-dev
index dbb1601..caa9527 100644 (file)
@@ -9,6 +9,3 @@ jupp source: testsuite-autopkgtest-missing
 
 # can’t use https because OpenSSL maintainer disabled TLSv1.0
 jupp source: debian-watch-uses-insecure-uri
-
-# don’t bother me with that
-jupp source: package-uses-old-debhelper-compat-version 9