oops, jessie backport shows code and comment bugs here
[alioth/musescore.git] / debian / patches / debian-specific / kfreebsd-oss-salsa.diff
index 9b48b64..be62486 100644 (file)
@@ -18,9 +18,9 @@ Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870787
 +// need to distinguish salsa from ALSA (hard because the former
 +// use, in Debian, the latter’s includes); one hackish way is
 +// to use the reported library version as salsa still reports
-+// version 1.0.x whereas ALSA on stretch shows 1.x (jessie also
-+// has 0.x, but even sloppy backports are closed, so we don’t
-+// need to worry about it any more). Simply inline the gist.
++// version 1.0.x whereas ALSA on stretch shows 1.1.x — jessie
++// also has 1.0.x, but we still can simply inline the gist as
++// the implementation is identical across OSS/jessie/buster.
 +// This is now https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870787
 +#if (SND_LIB_MAJOR < 2) && (SND_LIB_MINOR < 1)
 +#define snd_seq_event_length(ev) __extension__({              \
@@ -29,7 +29,7 @@ Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870787
 +      snd_seq_event_length__len = sizeof(snd_seq_event_t);    \
 +      if (snd_seq_ev_is_variable(ev))                         \
 +              snd_seq_event_length__len += ev->data.ext.len;  \
-+      (len);                                                  \
++      (snd_seq_event_length__len);                            \
 +})
 +#endif
 +