Fix bash 2.05b detection
authormirabilos <tg@mirbsd.org>
Fri, 19 Dec 2014 14:42:59 +0000 (15:42 +0100)
committermirabilos <tg@mirbsd.org>
Fri, 19 Dec 2014 14:42:59 +0000 (15:42 +0100)
commit39912f7b658ea3c975bfcdff315e2c84994e78c6
tree3d15f0b1f240975f42fa314c87a58d9ceb29dd94
parent93a088c5f6a8e407f669f9ed4176ce515a3ec84c
Fix bash 2.05b detection

GNU bash 2.05b does not do “{1..3}” expansion, which leads to mis-detecting
a fully patched bash on Debian sarge (my own packages) as vulnerable to
CVE-2014-7187 and missing CVE-2014-7187; expand those bashisms to keep
compatible and return correct values even for that version of GNU bash.
bashcheck